博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
hdu1250(Java)大数相加的问题
阅读量:5129 次
发布时间:2019-06-13

本文共 1337 字,大约阅读时间需要 4 分钟。

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10525 Accepted Submission(s): 3483

Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

 

Input
Each line will contain an integers. Process to end of file.
 

 

Output
For each case, output the result in a line.
 

 

Sample Input
100
 

 

Sample Output
4203968145672990846840663646

-------------------------------------------------

import java.math.BigDecimal;

import java.util.Scanner;

public class Main1250{

public static void main(String args[]){
Scanner cin=new Scanner(System.in);
BigDecimal []a=new BigDecimal[10007];
a[0]=new BigDecimal(1);
a[1]=new BigDecimal(1);
a[2]=new BigDecimal(1);
a[3]=new BigDecimal(1);
for(int i=4;i<10007;i++)
a[i]=a[i-1].add(a[i-2]).add(a[i-3]).add(a[i-4]);
while(cin.hasNext()){
int n=cin.nextInt();
System.out.println(a[n-1]);
}
}
}

----------------- 

Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 

这个地方要注意数组要开大点,题目不是说只有2005个数

转载于:https://www.cnblogs.com/1314wamm/p/5679622.html

你可能感兴趣的文章
jQuery EasyUI 的下拉选择combobox后台动态赋值
查看>>
timeline时间轴进度“群英荟萃”
查看>>
python if else elif statement
查看>>
网络编程
查看>>
文本隐藏(图片代替文字)
查看>>
java面试题
查看>>
提高码力专题(未完待续)
查看>>
pair的例子
查看>>
前端框架性能对比
查看>>
uva 387 A Puzzling Problem (回溯)
查看>>
12.2日常
查看>>
同步代码时忽略maven项目 target目录
查看>>
Oracle中包的创建
查看>>
团队开发之个人博客八(4月27)
查看>>
发布功能完成
查看>>
【原】小程序常见问题整理
查看>>
C# ITextSharp pdf 自动打印
查看>>
【Java】synchronized与lock的区别
查看>>
django高级应用(分页功能)
查看>>
【转】Linux之printf命令
查看>>